Big problems creating large (3D) environments

Problem 1: When i draw a wall in the drawing view and then stretch it 100 times for example, the line is getting stretched too and it’s getting really ugly.

Problem 2: Also on top of this horrible problem the snapping tool isn’t working well AT ALL (this is in the drawing view on a grid). Every snap is different from the other, depending on how far you’re zoomed in. This way it’s almost impossible to make a proper 3D cube.

What is the proper way of creating extremely large objects like a wall and snap them perfectly (in the drawing mode on grid points) so the wall lines cross at the exact same coordinates without gaps and overlaps in 3D?

For the line stretching try to convert it to brush! That way it may scale in proportion.

Now the line isn’t straight in some corners because the line now consists of 2 lines (contour?). Somehow it’s making the outside line round in some corners. Also, i’m not sure if the line is even unscaled now.

The 100 times streching I can’t help.
But when making a 3D cube you can enter position values in the layer properties. This can do precise work more exact and less timeconsuming. When you have a cube you are satisfied with you can store it in the global library and reuse and scale it as you like for future cubes.
For walls you can copy or clone the layer when windows and doors are placed
in the drawing. Then position the layers apart with the thickness of the wall.
If you want them in different colors use copy. If you want them to change simultaneously use clone.If you want to see how the wall develops while drawing use clone.If you want to change from clone to copy make a copy of the clone and hide or delete the clone.

Best regards

I actually wrote a script to help me make 3d shapes for the same reason as Ivaar. They are a real pain to set up exactly.

I think you build it to scale then uniformally scale it up.

That way you are doing super stretching which to me sounds very excessive and not needed.

Another option is zoom out a lot and draw it that way.


I’m not sure what you mean with it all. If you have a character that’s like 18 high on the grid, wouldn’t a wall be at least 5 times as big?

How do you make walls for big buildings then? Hasn’t anyone in the history of Animate ever made a wall wider than 24 on the grid then???

(The 3D placement to create a box is obviously no problem at all)

As Raider suggest.
To zoom out and draw it directly in full size will eliminate the scaling problem.
Scaling is usually no problem but it will scale the strokes width too.
To much scaling looks bad, I don’t know why.
For back grounds you can move them backwards in the scene but maintain their size in camera using the Maintain Size. You find it right clicking with the layer selected in top view(among others) . In the pop up menu
-Animation Tools - Maintain Size.

Best regards

I just like to work precise. I want to be able to create a character that’s 2 meter high, a wall that’s 10-20 meters wide and a door that’s 3 centimeters deep. I want all 3D objects to have to same line thickness. I want to be able to enter EXACT dimensions.

Anyone any idea if it’s even possible or should i change to Maya like more people are doing lately?

Guys, i’m in the right direction!

Now i’ve got it 100% working in OpenGL mode (when real-time antialiassing disabled) but not in render mode when you scale the axes individually :frowning:

I’ve enabled “adjust pencil line thickness” and “zoom independent thickness” (and left “normal thickness” enabled) in the advanced tab of the layer properties + i enabled “enable variable line thickness” in Edit > preferences > OpenGL

How can i get the same result in render that i have in OpenGL mode?

I’d have to see how you build it. It should work. Did you move the layers with 3D rotations? Or draw all in a flat way in Drawing view?

Can you make the scene or tpl available to see?