Auto tweening?

So I am learning this program and deformers, I am using envelope deformers, and I am having an issue with auto tweening, what I will do is keyframe a pose, keyframe another cell further down the timeline for a new pose but for some reason it’s tweened to the previous keyframe. I have my preferences set to Stop Motion but it does not stop the tweening, I know its fixable, maybe a setting? I have run into this problem before but I don’t remember how I fixed it. I feel like it’s something super simple. any ideas? Thanks!

You should be able to select the first key-frame and tell it to stop tweening. Right click - set stop motion keyframe, or Ctrl +L

Sometimes if a keyframe is made before you change the settings to stop motion it will already be a motion key.