Apply peg transformation and Z-depth issue

I’m trying to use the “tone module”, combined with the “apply peg transformation”, to place the shadow where I want it. The problem is that the character is animated along the z-axis and somehow this disconnects the shadow from the character, making the shadow slide over the character. I tried parenting the shadow peg to the characters main peg, which controls the z-depth animation, but no succes. So if I dissable the z-depth peg, the shadow is in place, as soon as I enable it, the shadow goes amok. How can I fix this?

The tone module is used to darken part of the character, it works
much like a highlight (only dark). The tone normally applies only
to the character - it doesn’t fall on objects/floors/walls.

Try using the “Shadow” node instead of a “Tone” node (module).

I’m aware of that, sorry if my post was unclear. So I’m trying to use the tone module to create an inner shading on the character, like an inverted rimlight. I set up the module like discribed in the tutorial about lighting and shading, but as soon as I enable the peg that controls the z-depth transformation, the shading isn’t fixed anymore and starts floating of the character.

Does your Node-View looks similar to this one ?

There’s actually a new effect in Harmony 12 specifically made for these types of things:

The tutorial by Adam Phillips explains the process:

Thank you very much rkriz for pointing that out…
The Light Shader Effect is working just marvellous.