animating multiple characters on same frame

hi i was wondering if anyone could help me out with a problem i’ve been having. I’m currently doing a photo animation with multiple characters in the same scene, i have no problem animating the first character whom only has 5 or 6 simple pegs in it. but my problem happens when i try to animate a second character whom has more than 12 peg’s. i notice that the first character on the timeline is represented by a green block, which i am able to copy and paste then extend exposure on then finish the initial animation but when i scroll down to the next character, to animate. he is represented as a blue block when the character peg’s are closed i try to copy and paste him to bring him in to animate. it will extend exposure throughout the whole animation. so i cannot animate two characters on the same camera view, without the second characters movements starting from the first frame to the current frame. so my question is, is there a way to animate multiple characters on the same frame. I’m talking about heavily pegged characters.

I’m sorry if you do not understand my problem. if you do not please just tell me how you animate more than one character on the same frame?
thank you.


In theory if you have put a master peg on both of your character your should be able to first animate the first character then once you are done with it collapse it’s master peg to avoid clogging the timeline and then work on the second one. Although I would need to see how you are setup in your scene do define what is going on so if possible could you upload a screenshot of your interface so we can see what is going on exactly.



Thanks for your reply i did my best to show what my problem is. take a look at the links in order from top to bottom. The problem is I’m trying to animate more than one character in the same scene and frame. when i animate the second character it automatically extends exposure, when i copy and paste him or change the starting frame. so is there a way to photo animate pegged characters in the same scene/frame?


Since your peg is collapsed the software will try to fill in the gaps between the last drawing and the place you pasted. Although you should be able to avoid this by using the Paste Special feature of the software (Command+B) in which you should uncheck the “Automatically extend the exposure” option.

Let us know if that is not what you were looking for.

Best regards,


thanks it appears to be working thank you very much.