Animate Timeline Slowdown

Hey fellow boomers,

I have an issue.

I wanted to buy ‘Animate Pro’ (AP) on an academic license to teach my students. I found out I couldn’t buy AP on an academic. I was annoyed, but decided to download ‘Animate’ PLE, to test the differences.

I pretty much came to the conclusion that Animate would be OK, (I’d also DL Pro) however it has severe problems that really hinder any progress of animating:

1. When you scrub the timeline, the playback on my PC is jittery, unresponsive - unusable.

2. Drawn shapes & Symbols take about a second to become highlighted once clicked on, and another 1-2 seconds to start moving once I drag them.

Painting is fine, filling colour is fine, and it even plays back correctly when played from the play button.

Can anyone tell me why Animate Pro & Animate have different performance on the same system?

It seems to be related to Symbols - when I make a symbol, everything slows right down

Unless this is something that can be resolved, I’ll have to look elsewhere, which is a shame, because I like the software and I’m sure ToonBoom would appreciate 100+ students a year being introduced to their program!

System Specs:

Intel Core2 Quad 2.84 GHz
4GB of RAM
ATI Radeon HD 4800

I hope someone can help,

Thanks - Matt
Senior Lecturer CGD at University of Newport Wales

Hi,

Try disabling the Anti-Aliasing of the software. This may help you speed up things. My guess is that the video card is not able to keep up with the refresh so lowering the task should help. Otherwise you may want to work things out in the Preferences under the OpenGL tab.

Best regards,

Ugo

Hi…

If the problem is not solved try disabling your network of the system and then try.



Hi Ugo,

From the system requirements, my card, and system are more than adequate to run animate. I tried all of your suggestions, and they didn’t work.

I_neel, what do you mean by disabling the network of the sytem? I’d very much like to try this.

Does it not seem strange that I can run Animate Pro fine, but Animate is glitchy? Surely this points to a different problem than my graphics card?

Regards,

Matt

Hi,

There were some enhancement on Animate Pro so it is possible you get different result in each of the software. This being said if the machine is indeed meeting the software requirements probably is related to something else.

First, make sure that you video card drivers are up to date.

Next, is this happening in brand new projects or only in projects you have been working on for some time?

Also, is this happening with both Brush and Pencil tool or only one of them?

Regards,

Ugo

Ugo,
I have 11gbs of RAM, MacPro dual-core xeon, 3 Ghz.
I am having issues of complete slowdown in AnimatePro (AP). I can’t use any rectangles, lines without waiting seconds for some response. I am using a tablet, with newest update. Have reset AP to default settings. Tried writing out 1,2,3…10 with brush, it was on 4 when I finished. Have restarted computer. Ran RAM test to make sure they are being used. Checked with Activity Monitor and it says that AP is using 187.22 MB of real memory, and 1.26 GB of virtual memory.

Also, question about locking layers, why are they always unlocked when I come back and try to use the program, yes I save before quitting.

Thanks,
-d

Hi,

Concerning the locking it is actually a temporary tool and is not actually saved inside the project file so it is the current behavior to not keep it. We could make a feature request to add such a feature.

Concerning the slowdown you may want to change some of your OpenGL options from the Toon Boom Animate Pro>… Preferences>OpenGL.

You could try changing the option of Alternate Gradient and Cutter, Real-Time Antialiasing among others.

Regards,

Ugo

Ugo,
I have shut off everything in the Open GL. I have a max text sixe of 2048. Text memory of -858993459. I still can’t do any lines or rectangles without waiting. Have deleted and reinstalled AP. Have an trial version of animate, no problem there. Will try redownloading and installing.

That would be great if there was something that could turn the locking on/off even after rebooting. Cause if someone had to go thru 50 layers of drawings every time they restarted the program, that is just insane.

Thanks,
-d

Ugo,
I am learning as soon as I add a symbol to the timeline, it crushes the speed of an lines, rectangles, etc that I try and do. What are good files to use such as psd, ai, swf? As well as size of info for each imported file, meaning, don’t want to bring in a gb file cause I would imagine that would stop the program. Is it best just to use psd files at a couple megs, and than recreate all the work in AP?

thanks,
-d

I have Animate (not Pro) and a similar problem.
After two days of working on a scene (3 minutes long, with not too much stuff in it, I mean not a big deal), it has become slow and unresponsive.
On top of it, it refuses to export a QT movie (unexpectedly quits!!).

I use a MacBook pro. Should be good enough.

Hey Josh,
I learned that you have to be careful with the file sizes that you import, no matter what the file size is. Especially scanned ones. I usually scan at 300 dpi because I would rather have the info, and than scale it down. BUT, AP gets sluggish once it is on the stage. What I have done is one of two things, either get my image created in AP, than delete it. Or clean it up in Flash or Illustrator, and than import it in AP.
Hope this helps,
-d

Hi,

The most important thing about file imported is actually their resolution. If a black and white file of 2000x1000 pixel is imported, even if it is 5-10k in file size the file need to be broken down pixel by pixel so it may end up being couple of Mo in memory. If you have multiple layer of psd always to try to keep them to the exact resolution they will need to be in the software. Making an image bigger then it’s original size inside Animate would result in a sharper result then actually scaling it down (it may seem backward but at the moment our upscale is more optimized then our downscale), so having too big of an image won’t give you any specific advantage.

Regards,

Ugo

One very simple trick that solves a laggy timeline is to turn off Auto Rendering in the Camera View options. Not sure if it’s anything to do with the issues you’re having but I thought I’d throw it out there.

Adam