Animate Pro 2 download

I own an Animate Pro 2 license. I am presently not in my habitual working place and don’t have the app on my laptop. This unfortunately is urgent. Is there a link where I can download it?

If you don’t know how to run terminal commands, you should have told them.
I’m sure they offered to remotely connect to your system. You will need
to allow someone to remotely connect as the fix for this is not easy to

Also note that Animate Pro 2 is not supported on Yosemite although it
is probably possible to get the software working on this O.S.

I think they should patch it so it works. I find out they patched Animate Pro 3. So it looks like they’re simply phasing out all previous customers.

As said, Anime Pro 2 is old but not prehistoric. It still does all the basic stuff Harmony does and until this incident it was working fine.

I understand a company not wanting to give away new features, but I can’t figure out why they’d let a 5 year old release become a total brick, creating thus problems for those who rely on the app for work. Unless the message is: “Upgrade or die”.

Support gave me some Terminal code which I am too ignorant to use. I said I’d try to type it in but, as predictable since I’m a cartoonist not a programmer, I didn’t get far.

Now I’ve written to Support again, let’s see what they say.

This is a total bummer, and - in my view - unfair treatment of customers.

If you must use Animate Pro 2 you should have a dedicated machine that can retain the most recent compatible OS.

I have software that runs best on 10.6.8 and am keeping it on a Mac Mini while I use a different system for Harmony and Yosemite.

hi o0Ampy0o

It’s not that I must because I’m particularly in love with Animate Pro 2, it’s that for what I need to do it was already more than what I needed.
I see how much better Harmony is but I simply don’t need all the new stuff. Support tells me ‘it probably could start up’ but then offers no active help. They sent me some code saying that erasing certain files via Terminal might help (I tried but didn’t get far due to my non-existent skills with code commands), so somewhere along the line Support acknowledges the problem and has a solution. It just looks like they are not willing to put a patch out there for everyone like they did for Animate Pro 3.

Yes, I agree with you, it’s a good idea to keep vintage software on machines with vintage systems.
But, at least in my experience, it takes a little more than five year for a program to become completely incompatible, i mean to the point it won’t even start up.
I have Adobe CS 3 (2008, if I’m not wrong) and it’s still running on my machine. It’s a but buggy, some extensions won’t work, but it does start up.

I still find it odd that Toon Boom created a patch for Animate Pro 3 (which is not that recent, either) and fixed it so it will run on Yoesemite whilst leaving Animate Pro 2 to its destiny.

Bottom line, it seems that as far as Toon Boom is concerned Animate Pro 3 users are still cool, they can use still their old software. Animate Pro 2 users no, they can buy or die.

Patching: To draw or not to draw the line at some version…why not two versions back? That seems reasonable to me. But first you have to agree that they ought to be able to draw the line somewhere.

Becoming obsolescent: Regardless of what you have observed it depends on what has been done in a version upgrade. Sometimes one upgrade can end compatibility.

Access to previous versions of software is part of the Gold Support Plan. Toon Boom might assist entities getting it up and running on an individual basis if they have this coverage…just speculating.

I suggest sticking with the compatible older OS over not having access to software any other way.

I hope you get the software running again.

It’s best to contact support for this as there is no actual error message and this
bouncing can have a lot of potential causes - mostly security related. It will
likely require examining your system and running some tests.

Maybe you are installing on an unsupported modern O.S. and they did not explained
their reasoning adequately…

Remember that a software can only work properly on the O.S. versions that existed
at the time this software version was released. Operating systems change and often
these changes “break” some functionality in the software. This and new functionalities
added to a program are the major reasons why new versions of the program are made
in the first place.

Try uninstalling and make sure to re-install from an Admin user account.
In the System Preferences’ “Security & Privacy” section, go to the “General”
tab and set “Allow applications downloaded from:” to “Anywhere” BEFORE
re-installing. otherwise it is almost certain that Apple’s very enthusiastic security
protocols will quarantine large parts of the program and prevent it from functioning
(including the License Wizard).

From your description, this is very likely to have happened (if you installed on a supported O.S. version).
Make sure to also activate the license from an Admin user account.

I am installing on Mac OS Yosemite, but the software doesn’t even start.
I am installing in my machine, as admin, all other software works fine, and I have already my Preferences set so any app can open.

Support told me to try writing some commands in Terminal but I’m not a programmer and I don’t know how to do that.

I need my Animate Pro 2 to just do some frame by frame animating. I don’t need any bone rigging for this project, so I wish I could use it.

I really feel let down by Toon Boom.

I did, but they said that Animate Pro 2 is not supported anymore.
This is really disappointing and a big problem because I need the software to work now. Big let-down.
I can see where it’s going: I’m going to have to upgrade to Harmony just to do the exact same thing I was doing with AP2. Frame by frame drawing hasn’t changed much and it was working fine for me.
AP2 is old but not prehistoric, it should still have some mileage to it.

I resent this fact, I think Toon Boom should keep all clients covered and happy, not just the latest upgraders.

Ok, I found Animate Pro 2 in my archive of purchases. I downloaded, dragged onto the Applications folder (MacOS) and tried to open it. It jumps up and down for about two minutes on the Dock and then stops without starting. I have to force quit it. I am in urgent need of using it and can’t seem to get it running.
I know the forum may not be the ideal place to solve this, but I’m hoping.
Thanks anyone out there! :slight_smile: