all film exports upside down

ok, it seems not to be my day today :frowning:
i can’t get ANY of the exports other than upside down.

i tried on two computers and with various export formats, display preferences, all to no avail.
i can vaguely remeber already having encountered this strange phenomenon once months before, but me fool haven’t wrtitten down how i eventually managed to get this done (or if it got healed by itself).

does anybody have a clue?
it’s a tbs 3.0.1 on a pc: a 750mhz p3 desktop and a 2.5ghz one in a laptop.

Are you serious ?

You really have the mother of all problems !! I’ve never seen this problem before.

A quick Fix would be to rotate the camera 180 degrees ;D

Seriously, could you send us a project for us to test. If so send it to

Have you tried exporting only the exposure sheet ? I’m guessing you are exporting the full movie right ?

Very strange …

i wish i wouldn’t. but it’s dead serious, and for the second time in a few months.
yes, it was a full export.
i’ll try a bit with exposure sheet exports.
if it doesn’t work i must prepare a mail version for you, because my free mailers accept only up to 20 mb at a time and i don’t want to split the whole, which is over 40mb drawing stuff, let alone the sound fx.
thanx and cheers,

it was not always so with the film.
only as the data amount grew, today the export decided to turn it upside down, just out of the blue.
and the preview of the same film is ok…
and here is the proof i wasn’t drinking (ok, at least not too much) :wink:


Well that’s special 0.o;

Since it wasnt like that before I’m just wondering if you installed something new in between the day it worked fine and the day it turned upside down ( new software, some driver update, any update of any software at all in fact ).

As for the mailing problem you could always use FTP to ship us the files.

We’ll be looking forward to hear from you.

Toon Boom Studio Tech Support

so ok, the issue wasn’t that dramatical.
mathieu, your statement about a quick fix with the camera rotation made me suspicious.

it was indeed a rotated performance in the camera view (although i have never touched the cam in this film, nor attached it to any peg).
but for some obscure reason either the camera or the drawing element got rotated by itself, namely at perfect 180°. that’s why each computer renders this upside down.

now i rotated the drawing element back in the camera view, but i have a few questions by the way:

1. my case was only one drawing element, but what happens when the whole scene has been split into many drawing elements? what’s the best method to fix this?

2. how can i rotate the camera in order to avoid the rotation of each drawing element (which may be a laborous and a complicated task. additionally i haven’t found any constraints to set the exact rotation angle in the camera view in the sceneplanning mode)?

could you please describe the exact procedure of a camera rotation? there 's nothing in the manual nor in the online help.

thanx in advance.

Hi rob,

For your first question I would say that best method would be to rotate camera. Else would be to select all drawing elements one by one and use the Tools/Transform/Rotate 180 ( alt+t then t then 1 ).

As for how you rotate the camera you simply need attach it to a peg then rotate the peg of 180 degrees. There is no actual parameter for the rotation on camera so you need to go through a peg. You can adjust the exact rotation you want with the function editor.

Hope this sums it up.


Hi Rob,

I sent you an email so you can send us some project file for testing. Let me know when it’s convenient for you.

Ugo’s information is correct. To make sure you have rotated 180 degrees, you can hold shift when adding rotation to the camera’s peg. Then the rotation will snap every 45 degrees.

Using the function editor is even more precise since you can actually enter the value of rotation in the lower left corner of the window.


ok guys, thanx for your assistance.
i’ve rotated the peg with the parented camera, but not in the ‘function editor’ (no inserted value remains in the text fields down left, they disappear when i unselect the keyframe) but in the ‘properties’ dialog.
it looks fine now, although i haven’t tested the export yet.

the question remains: how did the cam get rotated during the work?
i haven’t done anything else in the film except for drawing in a single drawing element and attaching audio tracks into a single sound element.

i’m relieved i have a ready fix for it, though.
thanx again.

I have no clue what could have append Rob sorry.

Send us your problematic project when you have more time.

It will help us to find the problem.


well, the same thing happened again.

i tried to insert a few additional frames into my project to make the opening movement more smooth. i used some of the frames of the still action in the beginning to exchange them with new frames of the first move of the guy.

i can’t say when (i didn’t control the camera view all the time) the drawing sequence turned upside down in the camera view.
most annoying that the credits sequence (which is in the other drawing element) remained as it should be, so the simple rotating of the camera at 180 degrees would wind up in an upside down credits and proper other drawings.

i couldn’t do anything except for saving the new sequence in the library and swapping the frames in the copy of the original animation, which was ok.

this is the already repaired film:

some re-drawing action on a ready film results in a rotation of the camera at 180 degrees in the referred drawing element. after it occurs, the camera rotation angle remains 0 degree in the properties window.

this for the second time in a few months.
i will closely scrutinize the thing in the camera view to report the exact moment of the occuring malfunction in my future projects, but something is not in order.

ok, tba guys,
the same thing happens again. i really don’t have a clue what’s goin’ on.

i put the whole folder with the film sketch on my web page. please look at it and tell me why the camera gets rotated, presumably after i add more drawing elements, but i can’t tell for sure.
thanks in advance.

my workaround at this time is to rotate the whole element (main menu > element > transform > flip vertical), but it can’t be a usual performance…

Hi Rob,

Would it be possible to zip the folder as it is impossible for me to download the folder (it just browse through them) and dont have any ftp address to log to.

Thank you,


ok, the winace archive is there already. thanks in advance.

Hi Rob,

I might have found the what is in cause. If you use the select tool from the sceneplanning tool and check the Drawing tab you will notice that one of the scale value is set to -1 on the drawing that is upside down. I simply put it back to 1 and it fixed the whole drawing element.

I am not quite sure what made this happen but this could give you a lead of what you might have done to get that value in there.

Best regards,


wow! :o

it seems to do the trick. but how do i come to the ‘-1’ value ??? i have definitely changed nothing there.
very strange…

thanks a lot :slight_smile:

Hi Rob,

I am not quite sure when exactly the flip was made. This might be related so some manipulation you have done in the function editor. In any case just let us know if you have any lead about where to look at.

Best regards,


hi ugo,
ok. i’ll try to keep an eye on it.