Adding a Peg to several composite groups

On one of my projects I was able to easily connect several composite groups to a master Peg so they could all be moved with one Peg. So, on another scene, I wanted to do the same but am unable to. If I add the Peg in the network view, the connections don’t connect. If I try adding a Peg in the timeline I get the message:

Cannot add Peg in this Display mode. Change to Display All mode.

So I opened the Display toolbar and set it to Display All, I can add the Peg and see it in the timeline but I still can’t make the connection in network view. Neither can I drag and drop a group onto it. I don’t understand what the difference is between these two scene files where it works in one and not the other. Anyone care to shed some enlightenment on this issue? Thanks!

Using always network view, I´d made a little test using three different groups of drawing elements, connected to a composite element, which in turn is connected to a write module and another display module, which is the display of the scene (composed by the images of the three groups). I then created a peg element, to which I connected the three groups, creating the typical pattern of connections. By assigning keyframes to the master peg I managed the three groups without difficulty. The active display has always been the default display of the scene, and the same in all the windows. The groups were set up with your own composite modules before the multiport out, as is normal. All this has worked quite normally, as you expressed to the first case. Next, I disconnected the master peg and created another in timeline, indenting the groups manually and the result was the same. I could not play this inability to connect the groups to the master peg, so we wait for the expert diagnosis of Toon Boom in this regard.

Best Regards

Thanks for looking into this, Yoryo! I don’t know what the difficulty is but it kind of stumped me. I wanted to attach two characters to a car that went across the page–last scene from my Good Neighbor animation–and I just could not attach them to the same Peg. So I had to move each element separately so they lined up properly. It worked okay, but every time I adjusted one I’d have to move the other two.

The Good Neighbor looks very great Zeb, in art and concept! Congratulations.
It really sounds incredible that characters can not be connected to the car through a common peg. Have you tried to assemble the same scene importing the templates of the individual characters to a new project? I would try to replace the simple groups by drawing elements test, without complications, to rule out incompatibility resides in either group, and then to check each particular module, as a possible cause of the problem, and create all the connections modules from the network view only, always checking the conections and using in all windows the display of the scene. In short, recreate your scene with very basic elements associated in the same way as the original, in the new scene. If that does work, then the problem may be in one of the original groups or modules. I use TBAPro2, but I think the operation is similar. What do you think?


Yeah, I’ll give it a try and see what happens. Thanks for the idea!

Check the color of your inports to the group. Is it Blue or Green? If it’s blue that why you can’t connect a peg (green) to that group. This can happen when you group some modules that has a ColorOverride one.

If this is the situation you have to disconnect and reconnect the modules inside the group to obtain that green port. Remember that the green port/cables are for position information and the blue are primeraly for image info. The blue can transfer position information also to a layer module but the peg needs a green cable/port.

Ah-ha! THAT helped me find the solution, Steve! Thanks! However it didn’t seem to be the ColorOverride that was causing the problem.

The two character groups I was trying to connect to the Peg indeed had blue input ports. When I opened each one there was no ColorOverride module used. But I noticed that where my MasterPeg was connected to the Input module it was blue. So I simply disconnected and reconnected the MasterPeg to the Input module and then the group input changed to green.

Now I was able to connect the Peg to the groups.

this thread just saved me a headache. i was having the same exact issue. i did what zeb suggested and it worked. why does it do this?

Hi everyone! Maybe I can make a ray of sunshine in your day by explaining for once and for all why it does this. :slight_smile:

The one really important thing to understand is how the Display works. What you see in the Camera View, as well as what you see in the Timeline, is all related to what the Display module is looking at.

By default, when you check out your Network View, the Display module is connected to the final composite in the scene. It’s always a good idea to leave that one there, and you can always add new Display modules for debugging. I’ll return to that concept in a moment.

So when you see your Camera View, you are seeing everything that is connected to your scene Composite, since that’s what the Display is connected to. This is the same thing with the Timeline.

When you add a Peg layer from your Timeline, if you already have a layer selected, then it makes this Peg a parent of the selected layer. Since the selected layer is already connected to the composite, the new parent peg is also connected to the composite, and voila!

The problem only arises when you try to create a Peg layer from the Timeline View, but don’t have a layer selected. This is the same thing as dragging a Peg layer into the Network View, or simply using the shortcut Ctrl-P or Cmd-P without having anything selected. What this does is it creates a floating Peg. Since this floating Peg is not connected to anything, it doesn’t show up in the Timeline!

In the Network View, this isn’t a problem, because you’re already looking at the Peg, so next thing you’re going to do is connect it to something. As soon as you connect it, it shows up in the Timeline.

If you try to do this in the Timeline View, it pops an error. Because what it would do is create a floating Peg, but then you wouldn’t be able to see it in the Timeline! You’d probably think something had gone wrong, and hit the button again. Next thing you know you could have a zillion floating pegs, but none of them would show up in the Timeline.

Generally, I do not recommend setting the display to Display All. What Display All actually does, is it does its best to display all the modules in the Camera and Drawing View, regardless of whether they are connected to the Composite. But this can be dangerous, because when you export out your final render, the final render only looks at things that are connected to the Composite. So something might not show up, and you could get confused.

So generally, I recommend doing the following:

  1. creating Pegs from the Timeline only when you can make it the parent of a selected layer, or
  2. creating Pegs directly in the Network View. You can use the shortcut Ctrl+P or Cmd+P to create a floating Peg, or you can select some modules and use the shortcut Ctrl+Shift+P or Cmd+Shift+P to make parent pegs of all the selected modules.

Hope this helps! I’ll also record a Tip of the Week on this one soon to help the understanding.


Thanks so much for the in depth explanation, Lilly! It really helped!

Floating Pegs! What won’t they think of next?!