3D renders with disappearing bitmaps

I finally got around to trying out the 3D features of Animate Pro. I made a room, the walls, ceiling and floor are vector rectangles filled with bitmap texture fills. It looked great in Open GL view (should’ve tried Render View). When I rendered the scene as an MOV they either do not appear or flicker on and off, mostly off.

So I thought there was a problem using bitmap textures and tried a different approach. I imported the textures as images vectorizing them in full color during the import. I rotated each piece to make the room and… same thing. Only this time, they don’t even flicker!

Vector objects render fine, but is it not possible for bitmaps–either used as textures or imported and vectorized–to render properly? Are they not supported?
Okay, found the glitch. You have to enable Euler angles instead of Quarternion. But it was still gltichy. When I set X to -90 on the floor it disappeared again. I had to manually rotate it with the 3D transform tool or click and drag on the function layer. Just typing in -90 and it would not show up.

The bitmaps were visible in Open GL view. It was the Render View where they would sometimes disappear. And it wasn’t because they were straight on. I was viewing in Perspective at about a 3/4 view.

The bitmaps were between 2-8 MB. The biggest one was 1180x1180, 150 dpi. You can see the 3D scene which is in my latest Tiny Bible Treasures 6, the scene inside a room near the end of the animation (at 2:30). The right and left walls are textured bitmaps.

If the Angle-y is exactly 90, the bitmap disappears. If I change the angle to 89.999 or less, the bitmap appears. This also happens with the floor and ceiling–weird!

Hi Zeb,

So I tried this myself both with bitmap images and with imported as vector. In both cases, with both euler and quaternion it worked. I typed in -90 in the x field, and at first it appeared to disappear, but in truth it’s just because it’s in the centre of the screen at we’re looking at it straight on like looking at a piece of paper. As soon as you move it down say -2 in the y position, then you see it again.

I never saw my image actually disappear in OpenGL.

When you see something in OpenGL and not in Render View, sometimes what happens is it might run out of memory as it’s rendering, and then it will just kind of bail out and not render that element on that frame. Are your bitmaps really high-res? What’s their resolution?


Well I’ll have to run some more tests!