16-17% CPU cap in Harmony

16-17% CPU cap in Harmony

Panning in Open GL view

Running as admin

Here are my specs:
Intel i7-4770K
WIN 8.1 Pro(64-bit)

Tried 2, 8 and 16 threads doesn’t make a difference

Open GL rendering is cone by the GPU not the CPU.
Do a real render (render network) to use the CPU for rendering.

Are you asking these questions because your rendering times are too long or
for other reasons?

when panning a scene becomes laggy when there is only one of my drawing assets its very frustrating

I’m just trying to understand where the bottlenecks are

and how I can optimize my workflow

I’ve isolated my modules into groups for each type of module, and found that using multiple cutters are a lot heavier then I thought,

even piping the finished modules into a single composite and then using a single cutter was heavy

baking a template out into single drawing layer composite module (with a “auto-refresh” check box) makes a lot of sense to me

If this is happening in the OpenGL view then a better graphic card would help avoid the bottleneck. As would using a single monitor rather than dual display. For Windows, avoiding the Aero Desktop theme and selecting a Basic & High contrast theme may help reclaim some resources.

If this is happening in the render view, you can tweak some options on the Render tab of the Stage preferences, such as render threads, creating a disc cache and modifying the Image Memory Limit.

Thank you for the suggestions :slight_smile:
I’ve received confirmation that harmony 11 will include better handling of multi-threading (so the 17% cap while panning is a limitation?). My graphics card’s GPU load only increases by 20% while panning, and the memory used is only 732 MB (out of 6 GB). So DEPENDING on whether the cpu bottleneck is the only issue here, this COULD also be gpu related.

I wonder if this only happens on windows?

this is the same for me, too. generally speaking my openGL view is fine, however it would be nice to be able to utilize more of my CPU for final renders to speed up the process. like you, bumping up the threads in the settings menus appears to do nothing. my final renders appear to cap out at 17% of the CPU.

As far as I know, CPU usage is calculated by the number of Cores…

If you use a Quad-Core processor each Core / Thread would give you 100 %…
8 Cores = 800 % with 16 Threads = 1600 % possible CPU usage…

Animate Pro 3 (don’t no about Harmony) might give on an 8 Core 16 Threads computer a CPU usage of about 130 %,
meaning it’s using about 8 % of the CPU.

An optimised application should give you on an 8 Core 16 Threads computer a CPU usage of about 1350 %,
it’s using about 84 % of the CPU.

Now that I’ve upgraded to Harmony 11, I no longer have this CPU cap issue in the Rendering View

its still present in the Open GL View

this is a nice update in harmony 11. renders certainly spit out faster, and its helpful for heavier scenes.